--> Konfigurasi Etherchannel PAgP Pada Switch Cisco Lab GNS3 | NetworkID

Friday, September 4, 2020

Konfigurasi Etherchannel PAgP Pada Switch Cisco Lab GNS3

| Friday, September 4, 2020

Etherchannel adalah cara menggabungkan banyak interface fisik maksimum 8 interface fisik menjadi satu interface logika dengan tujuan untuk meningkatkan kecepatan koneksi antar switch, Switch L3, ataupun server. Etherchannel akan tetap berjalan jika terjadi kerusakan pada salah satu port atau jalur antar switch, Switch L3, ataupun server menggunakan jalur yang ada, akan tetapi ada pengurangan kecepatan koneksi saja. 

Ada 3 cara untuk mengkonfigurasikan Etherchannel
1. PAgP (Port Aggregation Protocol ) merupakan Protocol milik Cisco yang hanya dapat berjalan di sesama perangkat cisco saja. Memiliki 2 mode Auto dan Desirable.
2. LACP (Line Aggregation Control Protocol) merupakan Protocol open standard IEEE802.3ad. Memiliki 2 mode Passive dan Active.
3. Static/manual  tanpa negosiasi dengan mode On.
 
Dalam tutorial ini saya akan mengimplementasikan Etherchannel PAgP (Port Aggregation Protocol) yang merupakan Protocol milik Cisco yang hanya dapat berjalan di sesama perangkat cisco saja.

Berikut topologi yang akan digunakan dalam tutorial ini.

Konfigurasi Etherchannel PAgP Pada Switch Cisco Lab GNS3
Dalam tutorial ini saya menggunakan ios gns3 versi
- Router  : Cisco IOS Software, 7200 Software (C7200-ADVENTERPRISEK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)
- Switch  : Cisco IOS Software, Linux Software (I86BI_LINUXL2-ADVIPSERVICESK9-M), Version 15.2

1. Konfigurasi Router Gateway 
ROUTER#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER(config)#int fa0/0
ROUTER(config-if)#no shutdown
ROUTER(config-subif)#encapsulation dot1Q 10
ROUTER(config-subif)#exit
ROUTER(config)#int fa0/0.10
ROUTER(config-subif)#no shutdown
ROUTER(config-subif)#ip add 192.168.10.254 255.255.255.0
ROUTER(config-subif)#exit
ROUTER(config-subif)#ip add 192.168.20.254 255.255.255.0
ROUTER(config)#int fa0/0.20
ROUTER(config-subif)#encapsulation dot1Q 20
ROUTER(config-subif)#no shutdown
ROUTER(config-subif)#ip add 192.168.30.254 255.255.255.0
ROUTER(config-subif)#exit
ROUTER(config)#int fa0/0.30
ROUTER(config-subif)#encapsulation dot1Q 30
ROUTER(config-subif)#no shutdown
ROUTER(config-subif)#ip add 199.199.199.254 255.255.255.0
ROUTER(config-subif)#exit
ROUTER(config)#int fa0/0.254
ROUTER(config-subif)#encapsulation dot1Q 254
ROUTER(config-subif)#no shutdown
ROUTER(config-subif)#exit
ROUTER#
ROUTER(config-if)#end
ROUTER#wr
Building configuration...
[OK]

2. Konfigurasi SWITCH-1

SWITCH-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH-1(config)#vlan 10
SWITCH-1(config-vlan)#name SERVER-1
SWITCH-1(config-vlan)#exit
SWITCH-1(config)#vlan 20
SWITCH-1(config-vlan)#name SERVER-2
SWITCH-1(config-vlan)#exit
SWITCH-1(config)#vlan 30
SWITCH-1(config-vlan)#name SERVER-3
SWITCH-1(config)#vlan 254
SWITCH-1(config)#int vlan 254
SWITCH-1(config-vlan)#name managemnet
SWITCH-1(config-vlan)#end
SWITCH-1#conf t
SWITCH-1(config)#int vlan 254
SWITCH-1(config-if)#ip address 199.199.199.1 255.255.255.0
SWITCH-1(config-if)#no shutdown
SWITCH-1(config-if)#exit
SWITCH-1(config)#
SWITCH-1(config)#ip default-gateway 199.199.199.254
SWITCH-1(config)#end
SWITCH-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH-1(config)#int e0/0
"interface ke arah server-1"
SWITCH-1(config-if)#switchport mode access
SWITCH-1(config-if)#switchport access vlan 10
SWITCH-1(config-if)#exit
SWITCH-1(config)#int e0/1
"interface ke arah server-2"
SWITCH-1(config-if)#switchport mode access
SWITCH-1(config-if)#switchport access vlan 20
SWITCH-1(config-if)#exit
SWITCH-1(config)#int e0/2
"interface ke arah server-3"
SWITCH-1(config-if)#switchport access vlan 30
SWITCH-1(config-if)#switchport mode access
SWITCH-1(config-if)#end
SWITCH-1#

3. Konfigurasi SWITCH-2

SWITCH-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH-2(config)#vlan 10
SWITCH-2(config-vlan)#name SERVER-1
SWITCH-2(config-vlan)#exit
SWITCH-2(config)#vlan 20
SWITCH-2(config-vlan)#name SERVER-2
SWITCH-2(config-vlan)#exit
SWITCH-2(config)#vlan 30
SWITCH-2(config-vlan)#name SERVER-3
SWITCH-2(config-vlan)#exit
SWITCH-2(config)#vlan 254
SWITCH-2(config-vlan)#name SERVER-4
SWITCH-2(config-vlan)#name management
SWITCH-2(config-vlan)#end
SWITCH-2#
SWITCH-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH-2(config)#int vlan 254
SWITCH-2(config-if)#ip add 199.199.199.2 255.255.255.0
SWITCH-2(config-if)#no shutdown
SWITCH-2(config-if)#exit
SWITCH-2(config)#
SWITCH-2(config)#ip default-gateway 199.199.199.254
SWITCH-2(config)#
SWITCH-2(config)#int e0/0 "interface ke arah komputer administrator"
SWITCH-2(config-if)#switchport mode access
SWITCH-2(config-if)#switchport access vlan 254
SWITCH-2(config-if)#end
SWITCH-2#

4. Konfigurasi Etherchannel PAgP Pada SWITCH-1

SWITCH-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH-1(config)#int port-channel 1
SWITCH-1(config-if)#switchport trunk encapsulation dot1q
SWITCH-1(config-if)#switchport trunk native vlan 254
SWITCH-1(config-if)#switchport mode trunk
SWITCH-1(config-if)#end
SWITCH-1#conf t
SWITCH-1(config)#int e0/3
"interface trunk ke arah router gateway"
SWITCH-1(config-if)#switchport mode trunk
SWITCH-1(config-if)#switchport trunk encapsulation dot1q
SWITCH-1(config-if)#exit
SWITCH-1(config)#
SWITCH-1(config)#int e1/0
SWITCH-1(config-if)#switchport trunk encapsulation dot1q
SWITCH-1(config-if)#switchport mode trunk
SWITCH-1(config-if)#channel-group 1 mode desirable
SWITCH-1(config-if)#channel-protocol pagp
SWITCH-1(config-if)#exit
SWITCH-1(config)#
SWITCH-1(config)#int e1/1
SWITCH-1(config-if)#switchport trunk encapsulation dot1q
SWITCH-1(config-if)#switchport mode trunk
SWITCH-1(config-if)#channel-group 1 mode desirable
SWITCH-1(config-if)#channel-protocol pagp
SWITCH-1(config-if)#exit
SWITCH-1(config)#
SWITCH-1(config)#int e1/2
SWITCH-1(config-if)#switchport trunk encapsulation dot1q
SWITCH-1(config-if)#switchport mode trunk
SWITCH-1(config-if)#channel-group 1 mode desirable
SWITCH-1(config-if)#channel-protocol pagp
SWITCH-1(config-if)#exit
SWITCH-1(config)#
SWITCH-1(config)#int e1/3
SWITCH-1(config-if)#switchport trunk encapsulation dot1q
SWITCH-1(config-if)#switchport mode trunk
SWITCH-1(config-if)#channel-group 1 mode desirable
SWITCH-1(config-if)#channel-protocol pagp
SWITCH-1(config-if)#end
SWITCH-1#
Compressed configuration from 2395 bytes to 1279 bytes[OK]
SWITCH-1#wr
Warning: Attempting to overwrite an NVRAM configuration previously written
by a different version of the system image.
Overwrite the previous NVRAM configuration?[confirm]
Building configuration...
SWITCH-1#

5. Konfigurasi Etherchannel PAgP Pada SWITCH-2

SWITCH-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH-2(config)#int port-channel 1
SWITCH-2(config-if)#switchport trunk native vlan 254
SWITCH-2(config-if)#switchport trunk encapsulation dot1q
SWITCH-2(config-if)#switchport mode trunk
SWITCH-2(config-if)#end
SWITCH-2#
SWITCH-2#conf t
SWITCH-2(config)#int e1/0
SWITCH-2(config-if)#switchport trunk encapsulation dot1q
SWITCH-2(config-if)#switchport mode trunk
SWITCH-2(config-if)#channel-protocol pagp
SWITCH-2(config-if)#channel-group 1 mode desirable
SWITCH-2(config-if)#exit
SWITCH-2(config)#
SWITCH-2(config)#int e1/1
SWITCH-2(config-if)#switchport trunk encapsulation dot1q
SWITCH-2(config-if)#channel-protocol pagp
SWITCH-2(config-if)#switchport trunk encapsulation dot1q
SWITCH-2(config-if)#channel-group 1 mode desirable
SWITCH-2(config-if)#exit
SWITCH-2(config)#
SWITCH-2(config)#int e1/2
SWITCH-2(config-if)#switchport mode trunk
SWITCH-2(config-if)#switchport trunk encapsulation dot1q
SWITCH-2(config-if)#channel-protocol pagp
SWITCH-2(config-if)#channel-group 1 mode desirable
SWITCH-2(config-if)#exit
SWITCH-2(config)#
SWITCH-2(config)#int e1/3
SWITCH-2(config-if)#switchport trunk encapsulation dot1q
SWITCH-2(config-if)#switchport mode trunk
SWITCH-2(config-if)#channel-group 1 mode desirable
SWITCH-2(config-if)#channel-protocol pagp
SWITCH-2(config-if)#end
SWITCH-2#
SWITCH-2#wr
by a different version of the system image.
Overwrite the previous NVRAM configuration?[confirm]
SWITCH-2#
Building configuration...
Compressed configuration from 2233 bytes to 1230 bytes[OK]

Konfigurasi switchport trunk native vlan 254 di interface port-channel otomatis terkonfigurasi juga di interface bundle etherchannel nya. contoh :

SWITCH-2#sh run int e 1/0
Building configuration...

interface Ethernet1/0
Current configuration : 179 bytes
!
switchport trunk native vlan 254
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol pagp
channel-group 1 mode desirable
end

SWITCH-2#

6. Verifikasi Konfigurasi SWITCH-1 dan SWITCH-2

SWITCH-1#sh int port-channel 1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is aabb.cc00.0101 (bia aabb.cc00.0101)
MTU 1500 bytes, BW 40000 Kbit/sec, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Auto-duplex, Auto-speed, media type is unknown
Keepalive set (10 sec)
input flow-control is off, output flow-control is unsupported
Members in this channel: Et1/0 Et1/1 Et1/2 Et1/3
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
Received 2543 broadcasts (0 multicasts)
5 minute output rate 2000 bits/sec, 3 packets/sec
12898 packets input, 1332334 bytes, 0 no buffer
0 runts, 0 giants, 0 throttles
70658 packets output, 5794790 bytes, 0 underruns
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
SWITCH-1#sh etherchannel summary
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
SWITCH-1#
Flags: D - down P - bundled in port-channel
M - not in use, minimum links not met
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

Number of aggregators: 1
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 1

Group Port-channel Protocol Ports
1 Po1(SU) PAgP Et1/0(P) Et1/1(P) Et1/2(P)
------+-------------+-----------+-----------------------------------------------
Et1/3(P)
SWITCH-1#sh run int port-channel 1
Building configuration...

!
Current configuration : 126 bytes
interface Port-channel1
switchport trunk native vlan 254
switchport trunk encapsulation dot1q
switchport mode trunk
end

SWITCH-1#
SWITCH-2#sh int port-channel 1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is aabb.cc00.0201 (bia aabb.cc00.0201)
MTU 1500 bytes, BW 40000 Kbit/sec, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Auto-duplex, Auto-speed, media type is unknown
Keepalive set (10 sec)
input flow-control is off, output flow-control is unsupported
Members in this channel: Et1/0 Et1/1 Et1/2 Et1/3
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 3 packets/sec
Received 56795 broadcasts (0 multicasts)
5 minute output rate 0 bits/sec, 0 packets/sec
67121 packets input, 4944529 bytes, 0 no buffer
0 runts, 0 giants, 0 throttles
16877 packets output, 2216219 bytes, 0 underruns
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
Flags: D - down P - bundled in port-channel
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
SWITCH-2#
SWITCH-2#sh etherchannel summary
I - stand-alone s - suspended
m - not in use, port not aggregated due to minimum links not met
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
------+-------------+-----------+-----------------------------------------------
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
1 Po1(SU) PAgP Et1/0(P) Et1/1(P) Et1/2(P)
Et1/3(P)
SWITCH-2#

7. Tes koneksi dari komputer Administrator ke Server-1, Server-2, dan Server-3

ADMIN> ping 192.168.10.1
84 bytes from 192.168.10.1 icmp_seq=1 ttl=63 time=18.001 ms
84 bytes from 192.168.10.1 icmp_seq=2 ttl=63 time=12.000 ms
84 bytes from 192.168.10.1 icmp_seq=4 ttl=63 time=19.001 ms
84 bytes from 192.168.10.1 icmp_seq=3 ttl=63 time=17.001 ms
84 bytes from 192.168.10.1 icmp_seq=5 ttl=63 time=19.001 ms
84 bytes from 192.168.20.1 icmp_seq=2 ttl=63 time=20.001 ms

ADMIN>
ADMIN> ping 192.168.20.1
84 bytes from 192.168.20.1 icmp_seq=1 ttl=63 time=21.002 ms
84 bytes from 192.168.20.1 icmp_seq=5 ttl=63 time=18.001 ms
84 bytes from 192.168.20.1 icmp_seq=3 ttl=63 time=19.001 ms
84 bytes from 192.168.20.1 icmp_seq=4 ttl=63 time=20.001 ms

ADMIN>
ADMIN> ping 192.168.30.1
84 bytes from 192.168.30.1 icmp_seq=3 ttl=63 time=19.001 ms
84 bytes from 192.168.30.1 icmp_seq=1 ttl=63 time=13.000 ms
84 bytes from 192.168.30.1 icmp_seq=2 ttl=63 time=19.001 ms
84 bytes from 192.168.30.1 icmp_seq=4 ttl=63 time=19.001 ms
84 bytes from 192.168.30.1 icmp_seq=5 ttl=63 time=20.001 ms

8. Tes koneksi dari Server-1, Server-2 dan Server-3 ke Komputer administraor

VLAN10> ping 199.199.199.250
84 bytes from 199.199.199.250 icmp_seq=1 ttl=63 time=17.001 ms
84 bytes from 199.199.199.250 icmp_seq=2 ttl=63 time=18.001 ms
84 bytes from 199.199.199.250 icmp_seq=4 ttl=63 time=17.001 ms
84 bytes from 199.199.199.250 icmp_seq=3 ttl=63 time=19.002 ms
84 bytes from 199.199.199.250 icmp_seq=5 ttl=63 time=20.001 ms
84 bytes from 199.199.199.250 icmp_seq=2 ttl=63 time=19.001 ms

VLAN10>

VLAN20> ping 199.199.199.250
84 bytes from 199.199.199.250 icmp_seq=1 ttl=63 time=17.001 ms
84 bytes from 199.199.199.250 icmp_seq=5 ttl=63 time=19.001 ms
84 bytes from 199.199.199.250 icmp_seq=3 ttl=63 time=18.001 ms
84 bytes from 199.199.199.250 icmp_seq=4 ttl=63 time=11.001 ms

VLAN20>

VLAN30> ping 199.199.199.250
84 bytes from 199.199.199.250 icmp_seq=3 ttl=63 time=17.000 ms
84 bytes from 199.199.199.250 icmp_seq=1 ttl=63 time=18.001 ms
84 bytes from 199.199.199.250 icmp_seq=2 ttl=63 time=19.001 ms
84 bytes from 199.199.199.250 icmp_seq=4 ttl=63 time=12.000 ms
84 bytes from 199.199.199.250 icmp_seq=5 ttl=63 time=19.001 ms

Terima kasih atas kunjunganya, semoga bermanfaat..

Related Posts

1 comment: