--> Konfigurasi Routing RIPv2 Pada Router Cisco Lab GNS3 | NetworkID

Sunday, August 23, 2020

Konfigurasi Routing RIPv2 Pada Router Cisco Lab GNS3

| Sunday, August 23, 2020

Routing Information Protocol (RIP) adalah sebuah protokol routing dinamis yang digunakan dalam jaringan LAN dan WAN. RIP mencegah routing loop dengan menerapkan batasan pada jumlah hop diperbolehkan dalam path dari sumber ke tempat tujuan. Jumlah maksimum hop diperbolehkan untuk RIP adalah 15. RIP memiliki dua versi, yaitu RIPv1 dan RIPv2. Dalam tutorial ini saya tidak membahas secara detail dan cara kerja RIP, namun saya akan memberi sedikit cara singkat untuk mengimplementasikan RIPv2.

Berikut topologi yang akan digunakan dalam tutorial ini.

Konfigurasi Routing RIPv2 Pada Router Cisco Lab GNS3

1. Konfigurasi Router R1

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int fa0/1
R1(config-if)#ip add 12.12.12.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
R1(config)#int fa0/0
R1(config-if)#ip add 192.168.1.254 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.1.0
R1(config-router)#network 12.12.12.0
R1(config-router)#no auto-summary
"Mencegah agar network-network tidak digabungkan menjadi classfull"
R1(config-router)#exit
R1(config)#

2. Konfigurasi Router R2

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int fa0/1
R2(config-if)#ip add 12.12.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int fa0/0
R2(config-if)#ip add 192.168.2.254 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 12.12.12.0
R2(config-router)#network 192.168.2.0
R2(config-router)#no auto-summary
"Mencegah agar network-network tidak digabungkan menjadi classfull"
R2(config-router)#exit
R2(config)#

3. Konfigurasi KOMPUTER-A

KOMPUTER-A> ip 192.168.1.1/24 192.168.1.254
Checking for duplicate address...
PC1 : 192.168.1.1 255.255.255.0 gateway 192.168.1.254
KOMPUTER-A>

4. Konfigurasi KOMPUTER-B

KOMPUTER-B> ip 192.168.2.1/24 192.168.2.254
Checking for duplicate address...
PC1 : 192.168.2.1 255.255.255.0 gateway 192.168.2.254
KOMPUTER-B>

5. Verifikasi RIPv2 dan konektivitas di router R1 dan R2

R1#sh ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
12.0.0.0/30 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/1
C 192.168.1.0/24 is directly connected, FastEthernet0/0

R 192.168.2.0/24 [120/1] via 12.12.12.2, 00:00:02, FastEthernet0/1
R1#

R1#sh ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 12 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet0/1 2 2

Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:

12.0.0.0
192.168.1.0

Routing Information Sources:
Gateway Distance Last Update

12.12.12.2 120 00:00:01
Distance: (default is 120)
R1#
R2#sh ip route 
*Mar 1 00:16:51.179: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
12.0.0.0/30 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/1
R 192.168.1.0/24 [120/1] via 12.12.12.1, 00:00:02, FastEthernet0/1
C 192.168.2.0/24 is directly connected, FastEthernet0/0
R2#
R2#sh ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet0/1 2 2

Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
12.0.0.0
192.168.2.0

Routing Information Sources:
Gateway Distance Last Update
12.12.12.1 120 00:00:16
Distance: (default is 120)
R2#

6. Tes koneksi dari KOMPUTER-A ke KOMPUTER-B

KOMPUTER-A> sh ip
NAME : KOMPUTER-A[1]
IP/MASK : 192.168.1.1/24
GATEWAY : 192.168.1.254
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10022
RHOST:PORT : 127.0.0.1:10023
MTU: : 1500

KOMPUTER-A> ping 192.168.2.1
84 bytes from 192.168.2.1 icmp_seq=1 ttl=62 time=62.400 ms
84 bytes from 192.168.2.1 icmp_seq=2 ttl=62 time=62.401 ms
84 bytes from 192.168.2.1 icmp_seq=3 ttl=62 time=62.401 ms
84 bytes from 192.168.2.1 icmp_seq=4 ttl=62 time=62.400 ms
84 bytes from 192.168.2.1 icmp_seq=5 ttl=62 time=40.002 ms
KOMPUTER-A>

7. Tes koneksi dari KOMPUTER-B ke KOMPUTER-A

KOMPUTER-B> sh ip
NAME : KOMPUTER-B[1]
IP/MASK : 192.168.2.1/24
GATEWAY : 192.168.2.254
DNS :
MAC : 00:50:79:66:68:01
LPORT : 10019
RHOST:PORT : 127.0.0.1:10021
MTU: : 1500

KOMPUTER-B> ping 192.168.1.1
84 bytes from 192.168.1.1 icmp_seq=1 ttl=62 time=62.400 ms
84 bytes from 192.168.1.1 icmp_seq=2 ttl=62 time=46.801 ms
84 bytes from 192.168.1.1 icmp_seq=3 ttl=62 time=62.400 ms
84 bytes from 192.168.1.1 icmp_seq=4 ttl=62 time=62.400 ms
84 bytes from 192.168.1.1 icmp_seq=5 ttl=62 time=41.003 ms
KOMPUTER-B>

Terima kasih atas kunjunganya, semoga bermanfaat.

Related Posts

No comments:

Post a Comment